博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
递归问题
阅读量:4489 次
发布时间:2019-06-08

本文共 2011 字,大约阅读时间需要 6 分钟。

问题:

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1
if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)
if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)
otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)
This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1 2 2 2 10 4 6 50 50 50 -1 7 18 -1 -1 -1
Sample Output
w(1, 1, 1) = 2 w(2, 2, 2) = 4 w(10, 4, 6) = 523 w(50, 50, 50) = 1048576 w(-1, 7, 18) = 1

 

回答:典型的记忆化递归问题

    #include <stdio.h>  

    #include <limits.h>  
      
    const int MAX_N = 21;  
    int W[MAX_N][MAX_N][MAX_N];  
      
    int getValue(int a, int b, int c)  
    {  
        if (a <= 0 || b <= 0 || c <= 0) return W[0][0][0] = 1;  
        if (a >= MAX_N || b >= MAX_N || c >= MAX_N)  
            return getValue(MAX_N-1, MAX_N-1, MAX_N-1);  
      
        if (W[a][b][c]) return W[a][b][c];  
      
        if (a < b && b < c)  
        {  
            W[a][b-1][c-1] = getValue(a, b-1, c-1);  
            W[a][b][c-1] = getValue(a, b, c-1);  
            W[a][b-1][c] = getValue(a, b-1, c);  
            return W[a][b][c] = W[a][b][c-1] + W[a][b-1][c-1] - W[a][b-1][c];  
        }  
      
        W[a-1][b-1][c-1] = getValue(a-1, b-1, c-1);  
        W[a-1][b-1][c] = getValue(a-1, b-1, c);  
        W[a-1][b][c-1] = getValue(a-1, b, c-1);  
        W[a-1][b][c] = getValue(a-1, b, c);  
      
        return W[a][b][c] = W[a-1][b][c] + W[a-1][b-1][c]  
        + W[a-1][b][c-1] - W[a-1][b-1][c-1];  
    }  
      
    int main()  
    {  
        int a, b, c;  
        while (~scanf("%d %d %d", &a, &b, &c)&& !(a == -1 && b == -1 && c == -1))  
        {  
            printf("w(%d, %d, %d) = %d\n", a, b, c, getValue(a, b, c));  
        }  
        return 0;  
    }

转载于:https://www.cnblogs.com/benchao/p/4496554.html

你可能感兴趣的文章
洛谷P1148 拱猪计分
查看>>
扑克序列
查看>>
java笔记--适配器模式的运用
查看>>
Replace Nested Conditional with Guard Clauses(用卫语句代替嵌套循环)
查看>>
jsp中${}是EL表达式的常规表示方式
查看>>
[Web Tools] 实用的Web开发工具
查看>>
ContentProvider
查看>>
欢迎来到Attention的博客
查看>>
获取IOS bundle中的文件
查看>>
document
查看>>
Hadoop下大矩阵乘法Version2
查看>>
iPhone内存溢出——黑白苹果
查看>>
Struts2学习笔记(十二) 类型转换(Type Conversion)(下)
查看>>
tcpdump学习
查看>>
局域网内传输文件速度慢
查看>>
Linux的核心版本(摘抄)
查看>>
CASE表达式
查看>>
zkw线段树
查看>>
作业1226
查看>>
mainline.js主线
查看>>